dcollector - 01/06/2018

Répondre


Cette question est un moyen d’empêcher des soumissions automatisées de formulaires par des robots.
Smileys
:-) :-( :-o :shock: :-? 8-) :lol: ;-) :-D :geek: :noob: :ugeek: :x :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :mrred: :plusun: :RER: :A: :B: :C: :D: :E: :M: :bus: :T: :train: :transilien: :ROR: :boing: :coool: :coucou: :cartonjaune: :cartonrouge: :dodo: :fouet: :fouette: :gratte: :mousse: :malade: :yes: :sulfateuse: :vache: :taz: :zik: :surprise: :hourra:
Voir plus de smileys

Les BBCodes sont activés
[img] est désactivé
[flash] est désactivé
[url] est activé
Les smileys sont activés

Revue du sujet
   

Étendre la vue Revue du sujet : dcollector - 01/06/2018

Re: dcollector - 01/06/2018

Message par Phil » 03 juin 2018, 21:06

Le cookie et notamment leur valeur m'ont permis de confirmer ma théorie, qui était que le problème ne venait que d'un des serveurs. Et vu que je savais comment du coup reproduire le bug à coup sûr, je l'ai fait sur ma machine et ait pu résoudre le bug.

Pour être complet, cela venait de l'adresse du serveur de base de données. Il y a quelques temps, OVH avait renommé tous ses serveurs de bases de données, mais en faisant toujours marcher les anciennes adresses. Enfin, c'est ce que je croyais. Ça ne doit pas être le cas sur les nouvelles machines qu'ils installent faut croire.
logique, la compatibilité (redirection alias DNS) ... est limité dans le temps, sinon au bout de qq modif cela devient ingérable
Phil

Re: dcollector - 01/06/2018

Message par Phil » 03 juin 2018, 21:05

oui, désolé... c'est JonathanMM ....encore toutes mes excuses ..
Merci !
Phil

Re: dcollector - 01/06/2018

Message par aquarius » 03 juin 2018, 12:43

Bonjour,
Merci Aquarius,
Non, non, merci Jonathan !

Re: dcollector - 01/06/2018

Message par JonathanMM » 03 juin 2018, 10:54

Le cookie et notamment leur valeur m'ont permis de confirmer ma théorie, qui était que le problème ne venait que d'un des serveurs. Et vu que je savais comment du coup reproduire le bug à coup sûr, je l'ai fait sur ma machine et ait pu résoudre le bug.

Pour être complet, cela venait de l'adresse du serveur de base de données. Il y a quelques temps, OVH avait renommé tous ses serveurs de bases de données, mais en faisant toujours marcher les anciennes adresses. Enfin, c'est ce que je croyais. Ça ne doit pas être le cas sur les nouvelles machines qu'ils installent faut croire.

Re: dcollector - 01/06/2018

Message par Phil » 03 juin 2018, 09:30

Bonjour,
Merci Aquarius, cela refonctionne sur Firefox sous ubuntu, Opera sous ubuntu et téléphone sous IOS

Cookie principal : R1790976967
Cookie secondaire : R3744882117

Etait ce bien la problématique lié au cookie par rapport à un serveur ?

Phil

Re: dcollector - 01/06/2018

Message par lelila » 02 juin 2018, 16:15

Ça marche pour la tablette

Re: dcollector - 01/06/2018

Message par aquarius » 02 juin 2018, 16:13

Ah, les barres de fin de message ont réapparu ! :-)

Re: dcollector - 01/06/2018

Message par JonathanMM » 02 juin 2018, 16:01

Ok, je crois avoir trouvé la source du problème. Est-ce que les gens chez qui ça ne marchait pas peuvent retester ?

Re: dcollector - 01/06/2018

Message par aquarius » 02 juin 2018, 14:11

Cookie principal : R3438189176
Cookie secondaire : R3744883206
et je n'ai pas d'affichage des statistiques dans les signatures

Re: dcollector - 01/06/2018

Message par lelila » 02 juin 2018, 12:58

Ne marche pas

Cookie principal : R3438189176
Cookie secondaire : R3744884295

A+
Lelila

Re: dcollector - 01/06/2018

Message par Claude » 02 juin 2018, 12:52

Cookie principal : R1790979145
Cookie secondaire : R3744883206
(pour un D-Co qui fonctionne normalement donc)

Re: dcollector - 01/06/2018

Message par JonathanMM » 02 juin 2018, 12:29

Est-ce que vous pourriez me donner ce que vous avez sur cette page, en précisant si ça marche ou pas : https://dcollector.sadur.org/debugcookie.php

Pour ceux qui veulent un peu plus de détail, OVH, notre hébergeur, fonctionne avec plusieurs serveurs pour un même site. Cela permet de mieux absorber le trafic qui arrive. Imaginons que le D-Collector utilise deux serveurs, A et B. Quand on va sur le D-Collector, OVH regarde quel est le serveur le moins pris, disons A, et va inscrire un cookie chez l'utilisateur pour savoir que lui pointe sur A. Cela permet par exemple qu'une fois connecté sur le D-Collector, il reste toujours sur le serveur A, et donc reste toujours connecté. Le problème de base de données doit provenir d'un des serveurs utilisés, qui doit avoir un problème. Les informations que je vous demande me permettront de valider ou pas ma théorie, et éventuellement de trouver le serveur incriminé en question ;)

Re: dcollector - 01/06/2018

Message par lelila » 02 juin 2018, 09:56

Toujours pas sur ma tablette sous chrome.
Fonctionne sur ke portable sous chrome. Je ressayerai tout à l'heure sur la tablette.

Re: dcollector - 01/06/2018

Message par 94RERD » 02 juin 2018, 08:52

Toujours pas sur ordinateur.

Re: dcollector - 01/06/2018

Message par lelila » 02 juin 2018, 07:32

Toujours pas sur ma tablette sous chrome.

Re: dcollector - 01/06/2018

Message par aquarius » 01 juin 2018, 22:17

Toujours pas sur mon PC, même message. Et les signatures sont marquées "Image" avec le picto d'image en vrac devant...

Re: dcollector - 01/06/2018

Message par JonathanMM » 01 juin 2018, 22:02

Tout à l'heure, je reproduisais sur mon téléphone ne 4G, et pas à la maison. Et maintenant, ça marche partout. Et vous ?

Re: dcollector - 01/06/2018

Message par Claude » 01 juin 2018, 20:54

:coucou:

C'est vraiment curieux :reflechis:

Chez moi ça fonctionne même avec le téléphone (Android, navigateur Samsung de base)

Je laisse les gourous résoudre ;-) C'est peut-être un bug lié à certains comptes ? Un ctrl + F5 et/ou un effacement des cookies pourrait résoudre ?

Re: dcollector - 01/06/2018

Message par lelila » 01 juin 2018, 18:57

A l'instant sur Chrome, c'est Connexion à MySQL impossible : SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known
Idem pour moi.

Re: dcollector - 01/06/2018

Message par Claude » 01 juin 2018, 17:54

A 17h50, chez moi, ça fonctionne (Firefox 60, Win 10)

Re: dcollector - 01/06/2018

Message par 94RERD » 01 juin 2018, 14:30

A l'instant sur Chrome, c'est Connexion à MySQL impossible : SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

Re: dcollector - 01/06/2018

Message par Phil » 01 juin 2018, 13:56

Bonjour,
essayé à l'instant (13h55) sur :
- Firefox sur OS linux ubuntu
- Operat sur OS linux ubuntu
- Firefox sur OS IOS

Résultat identique à chaque fois .. même message d'erreur

Phil

Re: dcollector - 01/06/2018

Message par aquarius » 01 juin 2018, 10:19

j'ai posé la même question au grand maître du D-Co ce matin, il m'a répondu que ça semblait aléatoire, n'arrivant qu'à quelques personnes mais pas à tout le monde. Et donc qu'un changement de connexion devrait pêrmettre le retour à un fonctionnement normal. Je n'ai pas testé pour l'instant.

dcollector - 01/06/2018

Message par Phil » 01 juin 2018, 09:06

Bonjour,

message lors de l'accès :
Connexion à MySQL impossible : SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known
--> mysql:host=localhost ?

Phil

Haut

cron